Changes between Version 4 and Version 5 of RequiredPackages/v9.1


Ignore:
Timestamp:
Dec 26, 2015 3:06:12 PM (21 months ago)
Author:
pbaumann
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • RequiredPackages/v9.1

    v4 v5  
    1212     * flex, bison, g++, libstdc++ -- required for compilation of the C++ codebase
    1313     * [http://openjdk.java.net/ OpenJDK 6+] -- required for compilation of the Java code (Java client API, petascope OGC frontend)
    14       - [http://tomcat.apache.org/ Tomcat] (or another suitable servlet container for deployment of petascope)
     14     * [http://tomcat.apache.org/ Tomcat] (or another suitable servlet container for deployment of petascope)
    1515   * '''general libraries:'''
    1616     * libssl-dev, libncurses5-dev, libedit-dev, libboost-dev (v1.48+), libffi-dev
    1717   * '''database stuff:'''
    18      * PostgreSQL (currently still mandatory for the petascope geo services component; optional for rasdaman array storage): [http://www.postgresql.org PostgreSQL 9.x] is recommended, but older versions will work fine as well (with exception of 8.3.0 to 8.3.6 inclusive); you need: [http://packages.debian.org/en/lenny/libecpg-dev libecpg-dev];
    19      * if rasdaman array storage is not using PostgreSQL (see above) then SQLite 3 will be used for rasdaman's technical metadata (libsqlite, libsqlite-dev and sqlite3 packages); see [wiki:Install#SQLiteFilesystembackend here]
     18     * PostgreSQL -- (currently still mandatory for the petascope geo services component; optional for rasdaman array storage): [http://www.postgresql.org PostgreSQL 9.x] is recommended, but older versions will work fine as well (with exception of 8.3.0 to 8.3.6 inclusive); you need: [http://packages.debian.org/en/lenny/libecpg-dev libecpg-dev];
     19     * libsqlite, libsqlite-dev and sqlite3 packages -- if rasdaman stores arrays in files instead of PostgreSQL then SQLite is needed for storing rasdaman's technical metadata; see [wiki:Install#SQLiteFilesystembackend SQLite in rasdaman]
    2020   * '''image formats:'''
    21      * libgdal-dev, libtiff-dev, libjpeg8-dev (we realized that this package name is changing over time, currently we find, e.g., libjpeg62-dev usable), [http://packages.debian.org/en/lenny/libpng12-dev libpng12-dev], [http://packages.debian.org/en/lenny/libnetpbm10-dev libnetpbm10-dev]
    22      * python-dateutil python-lxml python-pip python-gdal python-glob2 python-magic (required by [wiki:WCSTImportGuide wcst_import], a tool for importing geo-referenced data into rasdaman/petascope)
    23    * '''optional packages''' (use --with-XXX in the configure step to activate use by rasdaman):
     21     * libgdal-dev, libtiff-dev, libjpeg8-dev (we realized that this package name is changing over time, currently we find, e.g., libjpeg62-dev usable), [http://packages.debian.org/en/lenny/libpng12-dev libpng12-dev], [http://packages.debian.org/en/lenny/libnetpbm10-dev libnetpbm10-dev] -- for data import/export
     22     * python-dateutil python-lxml python-pip python-gdal python-glob2 python-magic -- required by the [wiki:WCSTImportGuide wcst_import] geo data ingest tool
     23   * '''optional packages''' (use `--with-XXX` in the configure step to activate):
    2424     * [http://packages.debian.org/en/lenny/libhdf4g-dev libhdf4g-dev], netcdf4
    25      * doxygen -- needed when --with-docs is specified
    26      * zmq, protobuf -- required only if rasdaman is compiled with `./configure` option `--enable-rasnet`
     25     * doxygen (needed when --with-docs is specified)
     26     * zmq, protobuf required by the new rasnet protocol (--enable-rasnet), more details [wiki:Install#rasnetcommunicationprotocol here]
    2727   * '''optionally''', the performance boosters and additional service components offered by [http://www.rasdaman.com rasdaman GmbH] can be installed.
    2828
    29 Next, continue with [wiki:InstallFromSource rasdaman compilation].
     29After this overview, best continue with [wiki:InstallFromSource rasdaman installation].