Changes between Version 11 and Version 12 of RequiredPackages/v9.1


Ignore:
Timestamp:
Dec 26, 2015 3:30:53 PM (21 months ago)
Author:
pbaumann
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • RequiredPackages/v9.1

    v11 v12  
    55Rasdaman requires a Linux kernel 2.6.18 or higher. Successful installations are reported for [wiki:Platforms many platforms].
    66
    7 Aside from the standard packages which should be available on any vanilla Linux, the following list has to be installed (e.g., via ''apt-get install ...''):
     7Aside from the standard packages which should be available on any vanilla Linux, the following list has to be installed for compilation / operation of rasdaman (note that this is just an overview, in the [wiki:InstallFromSource next step] you will get advised on package installation):
    88   * '''tools:'''
    99     * git -- needed to clone the rasdaman git repository
     
    1313     * [http://openjdk.java.net/ OpenJDK 6+] -- required for compilation of the Java code (Java client API, petascope OGC frontend)
    1414     * [http://tomcat.apache.org/ Tomcat] (or another suitable servlet container) -- required by petascope and SECORE servlets
    15    * '''libraries:'''
     15   * '''general libraries:'''
    1616     * libssl-dev, libncurses5-dev, libedit-dev, libboost-dev (v1.48+), libffi-dev
    17      * libgdal-dev, libtiff-dev, libjpeg8-dev, [http://packages.debian.org/en/lenny/libpng12-dev libpng12-dev], [http://packages.debian.org/en/lenny/libnetpbm10-dev libnetpbm10-dev]
    1817   * '''database stuff:'''
    1918     * PostgreSQL  [http://packages.debian.org/en/lenny/libecpg-dev libecpg-dev] -- optional for rasdaman array storage, still mandatory for the petascope geo services component; [http://www.postgresql.org PostgreSQL 9.x] is recommended, do not use 8.3.0 through 8.3.6
    2019     * libsqlite, libsqlite-dev and sqlite3 packages -- if rasdaman stores arrays in files instead of PostgreSQL then SQLite is needed for storing rasdaman's technical metadata; see [wiki:Install#SQLiteFilesystembackend SQLite in rasdaman]
    21    * '''optional packages''':
     20   * '''image formats:'''
     21     * libgdal-dev, libtiff-dev, libjpeg8-dev, [http://packages.debian.org/en/lenny/libpng12-dev libpng12-dev], [http://packages.debian.org/en/lenny/libnetpbm10-dev libnetpbm10-dev]
    2222     * python-dateutil python-lxml python-pip python-gdal python-glob2 python-magic (required by [wiki:WCSTImportGuide wcst_import], a tool for importing geo-referenced data into rasdaman/petascope)
    23      * doxygen -- required for generation of HTML documentation when configured with option --with-docs`
    24      * [http://packages.debian.org/en/lenny/libhdf4g-dev libhdf4g-dev] -- required for HDF4 support, activated with option `--with-HDF`
    25      * netcdf4 -- required for NetCDF support, activated with option `--with-netcdf`
    26      * zmq, protobuf -- required for rasnet client/server communication protocol support, activated with option `--enable-rasnet`
    27      * the performance boosters and additional service components offered by [http://www.rasdaman.com rasdaman GmbH]
     23   * '''optional packages''' (use --with-XXX in the configure step to activate use by rasdaman):
     24     * [http://packages.debian.org/en/lenny/libhdf4g-dev libhdf4g-dev], netcdf4
     25     * doxygen -- required when configured with option --with-docs`
     26     * zmq, protobuf -- required when configured with option `--enable-rasnet`
     27   * '''performance boosters''' -- optional, provided by [http://www.rasdaman.com rasdaman GmbH]
    2828
    2929Next, continue with [wiki:InstallFromSource rasdaman compilation].