Changes between Version 37 and Version 38 of InstallFromSource


Ignore:
Timestamp:
Mar 1, 2017 11:52:10 AM (6 months ago)
Author:
anasiri
Comment:

'--enable-rasnet' is a deprecated option since rasdaman v9.2

Legend:

Unmodified
Added
Removed
Modified
  • InstallFromSource

    v37 v38  
    2929  * libssl-dev, libncurses5-dev, libedit-dev, libboost-dev (v1.48+), libffi-dev -- required for various system tasks
    3030  * libgdal-dev, libtiff-dev, libjpeg8-dev, [http://packages.debian.org/en/lenny/libpng12-dev libpng12-dev], [http://packages.debian.org/en/lenny/libnetpbm10-dev libnetpbm10-dev] -- required fro data format support
     31  * grpc, protobuf -- required for the rasnet client/server protocol
    3132* '''database stuff:''' Pick one option below for rasdaman storage:
    3233  * [http://packages.debian.org/en/lenny/libecpg-dev libecpg-dev] -- required for [http://www.postgresql.org PostgreSQL] (version 9.x is recommended; 8.3.0 to 8.3.6 known to '''not''' work) to hold rasdaman arrays and/or petascope geo metadata
     
    3637  * netcdf4 -- required for NetCDF support, configure with `--with-netcdf`
    3738  * doxygen -- required for HTML system documentationm configure with `--with-docs`
    38   * grpc, protobuf -- required for the rasnet client/server protocol, configure with `--enable-rasnet`
    3939  * [http://tomcat.apache.org/ Tomcat] (or another suitable servlet container) -- required for running the petascope and SECORE servlets; default, changed to embedded jetty support with `--enable-jetty`
    4040  * r-base, r-base-dev -- required for [wiki:RRasdaman], a R package providing database interface for rasdaman