Opened 3 years ago

Closed 2 years ago

#898 closed defect (fixed)

WMS fails to load service table

Reported by: dmisev Owned by: mdumitru
Priority: major Milestone: 9.1
Component: petascope Version: development
Keywords: Cc: pbaumann
Complexity: Medium

Description

Just after freshly creating a database with update_petascopedb.sh. Postgres version 9.1.10

  INFO [20:19:13] CommanderConnection@236: createStatement()
  INFO [20:19:13] Table_Service@504: Table_Service::fetchAllTuples()
  INFO [20:19:13] Table_Service@514: Table_Service::next()
  INFO [20:19:13] Table_Service@567: Table_Service::close()
  INFO [20:19:13] Table_Service@575: Table_Service::close()
  INFO [20:19:13] Table_Service@555: Table_Service::next() -> false
 ERROR [20:19:13] DatabaseConfigAdapter@93: Error: Failed to find service definition in database:Error: Service not found.
 ERROR [20:19:13] WMSException@228: WMSException::WMSException(302,null): warning: general exception while trying to open message file null; no texts will be available.
 ERROR [20:19:13] PetascopeInterface@189: WMS 1.1.0 could not be initialized due to {}
javax.servlet.ServletException: <?xml version='1.0' encoding="UTF-8" standalone="no" ?>
<!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.0/exception_1_1_0.dtd">
<ServiceExceptionReport version="1.1.0">
  <ServiceException code="(no text available)">
    GWMS302: (no text available)
  </ServiceException>
</ServiceExceptionReport>

	at petascope.wms.WmsConfig.initFromDatabase(WmsConfig.java:182)
	at petascope.wms.WmsServlet.init(WmsServlet.java:206)
	at petascope.wms2.servlet.PetascopeInterfaceAdapter.initWMS11Servlet(PetascopeInterfaceAdapter.java:67)
	at petascope.PetascopeInterface.init(PetascopeInterface.java:185)
	at javax.servlet.GenericServlet.init(GenericServlet.java:212)
	at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)
	at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1026)
	at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4421)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4734)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
	at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:675)
	at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:601)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)
	at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
	at org.apache.catalina.core.StandardService.start(StandardService.java:525)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
  INFO [20:19:13] PetascopeInterface@194: WCS: Initialization ...
  INFO [20:19:13] PetascopeInterface@196: WCS: Initialization complete.

Change History (3)

comment:1 Changed 3 years ago by dmisev

  • Priority changed from blocker to major

comment:2 Changed 2 years ago by dmisev

Ok most likely the add_wms_service.sh needs to be run. I changed it to just display a proper warning in this case.

comment:3 Changed 2 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.