Opened 2 years ago

Closed 23 months ago

#890 closed defect (invalid)

rasimport segfault when reading image information

Reported by: dmisev Owned by: dmisev
Priority: major Milestone: 9.1
Component: rasgeo Version: development
Keywords: Cc: aherzig, jiezhou87@…
Complexity: Medium

Description

Segmentation fault caught, stacktrace:
[bt]: (1) /lib/x86_64-linux-gnu/libc.so.6 (??:0) - (null)+0x2a [0x7f7176e7f92a]
[bt]: (2) /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (??:0) - std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(char const*, std::allocator<char> const&)+0x25 [0x7f7177793ee5]
[bt]: (3) rasimport (stl_vector.h:903 (discriminator 3)) - readTileInformation(GDALDataset*, Header&)+0x69 [0x4449f9]
[bt]: (4) rasimport (rasimport.cc:359) - readImageInformation(std::vector<std::string, std::allocator<std::string> >&, Header&, std::vector<double, std::allocator<double> >&, std::vector<std::string, std::allocator<std::string> >&, bool, double)+0x1c3 [0x4459a3]
[bt]: (5) rasimport (stl_vector.h:646) - (null)+0x1b70 [0x43f7d0]
[bt]: (6) /lib/x86_64-linux-gnu/libc.so.6 (??:0) - (null)+0xf5 [0x7f7176e17ec5]
[bt]: (7) rasimport() [0x4424bf]

rasimport command is

rasimport  -f "${tiffile}"  \
--coll ${coll_name} \
--3D top \
-t ShortCube:ShortSet3  \
--coverage-name ${cov_name} \
--tiling 'TILING regular [0:999,0:499,0:0]' \
--crs-order 1:0:2 \
--crs-uri '%SECORE_URL%/crs/EPSG/0/4326':'%SECORE_URL%/crs/OGC/0/AnsiDate' \
--csz 16 \
--shift 0:0:$ansidt

$tiffile is attached.

Attachments (2)

mod13a2_1 km 16 days NDVI.tif.tar.gz (3.6 MB) - added by dmisev 2 years ago.
reproduce.sh (383 bytes) - added by dmisev 2 years ago.

Change History (4)

Changed 2 years ago by dmisev

Changed 2 years ago by dmisev

comment:1 Changed 2 years ago by dmisev

I could not reproduce the error with the attachment:reproduce.sh script and the attached input file. I've set $ansidt to 1, not sure if it is correct or not.

comment:2 Changed 23 months ago by dmisev

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.