Opened 3 years ago

Closed 3 years ago

#811 closed task (fixed)

Substitute libsigsegv with non GPL code/lib

Reported by: dmisev Owned by: bthapaliya
Priority: major Milestone: 9.0.x
Component: build system Version: development
Keywords: Cc: pbaumann
Complexity: Medium

Description

libsigsegv should be replaced with a non GPL alternative. These are the places where it is used in rasdaman:

$ grep -R sigsegv *
applications/rasql/rasql.cc:#include <sigsegv.h>
applications/rasql/rasql.cc:    sigsegv_install_handler(&handler);
applications/rasgeo/raserase.cc:#include <sigsegv.h>
applications/rasgeo/raserase.cc:    sigsegv_install_handler(&handler);
applications/rasgeo/rasimport.cc:#include <sigsegv.h>
applications/rasgeo/rasimport.cc:    sigsegv_install_handler(&handler);
config.h.in:/* Define to 1 if you have the `sigsegv' library (-lsigsegv). */
configure.ac:AC_CHECK_LIB([sigsegv], [sigsegv_install_handler], , [AC_MSG_RESULT(no)])
packaging/debian/generate_debian_package.sh:RASDAMAN_BUILD_DEPENDENCIES="libgdal-dev autoconf automake autotools-dev bison comerr-dev flex gawk git-core g++ krb5-multidev libecpg-compat3 libecpg-dev libecpg6 liberror-perl libgfortran3 libgssrpc4 libjpeg62-dev libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4 libkrb5-dev libltdl-dev libncurses5-dev libnetpbm10-dev libpgtypes3 libpng12-dev libpq-dev libedit-dev libssl-dev libtiff4-dev libtiffxx0c2 libtool m4 postgresql-8.4 postgresql-common zlib1g-dev doxygen openjdk-6-jdk tomcat6 libxp-dev libsigsegv-dev"
packaging/debian/generate_debian_package.sh:RASDAMAN_BUILD_DEPENDENCIES_ONEIRIC="libgdal-dev autoconf automake autotools-dev bison comerr-dev flex gawk git-core g++ krb5-multidev libecpg-compat3 libecpg-dev libecpg6 liberror-perl libgfortran3 libgssrpc4 libjpeg62-dev libkadm5clnt-mit8 libkadm5srv-mit8 libkdb5-5 libkrb5-dev libltdl-dev libncurses5-dev libnetpbm10-dev libpgtypes3 libpng12-dev libpq-dev libedit-dev libssl-dev libtiff4-dev libtiffxx0c2 libtool m4 postgresql-8.4 postgresql-common zlib1g-dev doxygen openjdk-6-jdk tomcat6 libxp-dev libsigsegv-dev"DEBIAN_BUILD_DEPENDENCIES="devscripts build-essential ubuntu-dev-tools debhelper fakeroot"
packaging/rpm/rasdaman.spec:BuildRequires: libsigsegv-devel
packaging/rpm/rasdaman.spec:- Add libsigsegv-devel dependency
raslib/commonutil.cc:#include <sigsegv.h>
server/rasserver_main.cc:#include <sigsegv.h>
server/rasserver_main.cc:    sigsegv_install_handler(&handler);

Change History (2)

comment:1 Changed 3 years ago by bthapaliya

Patch submitted.

comment:2 Changed 3 years ago by bthapaliya

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.