Opened 3 years ago

Closed 3 years ago

#785 closed defect (fixed)

Implement WCS Range Subsetting extension

Reported by: pcampalani Owned by: pcampalani
Priority: major Milestone: 9.0.x
Component: petascope Version: development
Keywords: wcs range subsetting extension Cc:
Complexity: Medium

Description

Reference ticket for the implementation of the WCS Range Subsetting extension (OGC 12-040).

This has been implemented already 1.5 years ago (see changeset:0e0d1e2) when ticket reference in patches was still not mandatory. Need to create it now since a few more fixes were needed for a fully compliant extension implementation.

Change History (3)

comment:1 Changed 3 years ago by pcampalani

  • Status changed from new to accepted

comment:2 Changed 3 years ago by pcampalani

Issues to be fixed:

  • throw an IllegalFieldSequence exception on illegal range field intervals;
  • HTTP code to be 404 for NoSuchField exception
  • GetCoverage range type description to be updated when range subsetting is used
  • #756 (WCPS to use GMLCOV field names instead of streamlining field names to RasQL as-is)

comment:3 Changed 3 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from accepted to closed

Extension fixed in changeset:a519796.

Note: See TracTickets for help on using tickets.