Opened 3 years ago

Closed 3 years ago

#689 closed enhancement (invalid)

Importing BGS sample tin data into postgis

Reported by: arezaeim Owned by: pbaumann
Priority: minor Milestone: 9.0.x
Component: petascope Version: development
Keywords: Cc: pcampalani, pbaumann
Complexity: Medium

Description

The data is stored in tsurf format in which first the vertices and their coordinates in 2D listed with a data value (elevation) and then the triangles are listed.

Change History (8)

comment:1 Changed 3 years ago by dmisev

  • Priority changed from major to critical

The WCPS test fails now for me

test.sh: deleting coverage wc_dtm_small from petascope... ok.
test.sh: done.
test.sh: importing wc_dtm_small... grep: /home/dimitar/projects/rasdaman/community/src/systemtest/testcases_services/test_wcps/testdata/wc_dtm_small.ts: No such file or directory
grep: /home/dimitar/projects/rasdaman/community/src/systemtest/testcases_services/test_wcps/testdata/wc_dtm_small.ts: No such file or directory
/home/dimitar/projects/rasdaman/community/src/systemtest/util/petascope.sh: line 926: /home/dimitar/projects/rasdaman/community/src/systemtest/testcases_services/test_wcps/testdata/wc_dtm_small.ts: No such file or directory
expr: syntax error
awk: cmd. line:2: NR >= 
awk: cmd. line:2:       ^ unexpected newline or end of string
ERROR:  relation "ps_multisurface" does not exist
LINE 1: ...|| St_YMin(ST_Extent(surface))   FROM ps_coverage,ps_multisu...
                                                             ^
ERROR:  relation "ps_multisurface" does not exist
LINE 1: ...|| St_YMax(ST_Extent(surface))   FROM ps_coverage,ps_multisu...
                                                             ^
ERROR:  new row for relation "ps_bounding_box" violates check constraint "upper_right_is_not_empty"

comment:2 Changed 3 years ago by dmisev

  • Cc pcampalani added

Same for WCS and WMS tests.

comment:3 Changed 3 years ago by dmisev

  • Cc pbaumann added
  • Owner changed from arezaeim to pbaumann
  • Status changed from new to assigned

It seems like the issue is because of some pending patches, so reassigning to Peter.

comment:4 Changed 3 years ago by dmisev

While we are here, I'd like to propose that we adhere to self-containing patches that do not break things, and do not depend on other patches.

comment:5 Changed 3 years ago by arezaeim

I thought since they all are labelled with the same ticket number will be applied together.

comment:6 Changed 3 years ago by dmisev

Not sure, what is the status of this ticket? Should it be closed? Otherwise, should it still be critical?

comment:7 Changed 3 years ago by dmisev

  • Priority changed from critical to minor

comment:8 Changed 3 years ago by dmisev

  • Resolution set to invalid
  • Status changed from assigned to closed

I assume expired, please complain if it isn't the case.

Note: See TracTickets for help on using tickets.