Opened 4 years ago

Closed 4 years ago

#638 closed defect (fixed)

CSV encoding problem with multiband collections

Reported by: pcampalani Owned by: uagha
Priority: blocker Milestone: 9.0
Component: conversion Version: development
Keywords: csv encoding multiband rgb Cc: dmisev
Complexity: Hard

Description

CSV does not seem to provide idempotent responses with multiband collections:

$ rasql -q "select csv(c) from rgb AS c" --out string > out1.tmp
$ rasql -q "select csv(c) from rgb AS c" --out string > out2.tmp
$ diff out1.tmp out2.tmp

Looking at the outputs, there are some contiguous values which change, others do not.

This does not seem to happen with single band collections (I tried mr)

Change History (5)

comment:1 Changed 4 years ago by dmisev

  • Owner changed from dmisev to uagha
  • Status changed from new to assigned

Ok this is bug introduced by Uneeb..

Uneeb I thought you have fixed the csv system test?? This is what I get (the second test is rgb:

test.sh: ----- csv and inv_csv conversion ------
test.sh: creating collection... ok.
test.sh: inserting data... ok.
test.sh: selecting data... ok.
test.sh: comparing images: input and output match
test.sh: ----- csv and inv_csv conversion ------
test.sh: creating collection... ok.
test.sh: inserting data... ok.
test.sh: selecting data... ok.
test.sh: comparing images: input and output do not match

comment:2 Changed 4 years ago by dmisev

Piero since you've recompiled, can you re-test this one?

comment:3 Changed 4 years ago by pcampalani

Yes of course.. Unluckily it is still there!

comment:4 Changed 4 years ago by dmisev

Patch submitted, confirmed to work by both me and Piero.

comment:5 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.