Opened 3 years ago

Closed 3 years ago

#544 closed defect (fixed)

WC*S tests with geo binary output encoding fail

Reported by: dmisev Owned by: pcampalani
Priority: critical Milestone: 9.0
Component: petascope Version: development
Keywords: geo encoding tiff jp2 Cc:
Complexity: Medium

Description

Below is the result of running the WCPS test:


systemtest/testcases_services/test_wcps$ cat failed_cases 
----------------------------------------------------------------------
52-gtiff-params-filling.test
for c in (eobstest) return encode(
  c[
    t(1),
    Long:"http://www.opengis.net/def/crs/EPSG/0/4326" (20:35),
    Lat:"http://www.opengis.net/def/crs/EPSG/0/4326" (10:15)]),
"tiff", "nodata=0")
----------------------------------------------------------------------
53-jpeg2000-params-filling.test
for c in (eobstest) return encode(
  c[
    t(1),
    Long:"http://www.opengis.net/def/crs/EPSG/0/4326" (20:35),
    Lat:"http://www.opengis.net/def/crs/EPSG/0/4326" (10:15)]),
"jpeg2000")
----------------------------------------------------------------------
73-rasutil-query-metadata-t422.test
for c in (mean_summer_airtemp) return crsSet(c)----------------------------------------------------------------------
81-gtiff_extend.test
for t in (eobstest) return encode(extend( t[t(1)],  { Long(-45:90),  Lat(5:80) }, "tiff" )
----------------------------------------------------------------------
82-timestamp_in_subset.test
for c in (eobstest) return encode(
  c[
    t("1950-01-02"),
    Long(20:35),
    Lat(10:15)]),
"tiff")

systemtest/testcases_services/test_wcps$ cat output/73-rasutil-query-metadata-t422.test.out 

systemtest/testcases_services/test_wcps$ gdalinfo output/82-timestamp_in_subset.test.out 
Driver: GTiff/GeoTIFF
Files: output/82-timestamp_in_subset.test.out
Size is 21, 11
Coordinate System is `'
Origin = (0.000000000000000,0.000000000000000)
Pixel Size = (0.000000000000000,0.000000000000000)
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (   0.0000000,   0.0000000) 
Lower Left  (   0.0000000,   0.0000000) 
Upper Right (   0.0000000,   0.0000000) 
Lower Right (   0.0000000,   0.0000000) 
Center      (   0.0000000,   0.0000000) 
Band 1 Block=21x11 Type=Int16, ColorInterp=Gray
  NoData Value=0

systemtest/testcases_services/test_wcps$ gdalinfo output/81-gtiff_extend.test.out 
Driver: GTiff/GeoTIFF
Files: output/81-gtiff_extend.test.out
Size is 271, 151
Coordinate System is `'
GCP Projection = 
GCP[  0]: Id=1, Info=
          (0,0) -> (5.53353523342196e-322,2.19695340705942e-316,0)
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (    0.0,    0.0)
Lower Left  (    0.0,  151.0)
Upper Right (  271.0,    0.0)
Lower Right (  271.0,  151.0)
Center      (  135.5,   75.5)
Band 1 Block=271x15 Type=Int16, ColorInterp=Gray
  NoData Value=0

systemtest/testcases_services/test_wcps$ gdalinfo output/52-gtiff-params-filling.test.out 
Driver: GTiff/GeoTIFF
Files: output/52-gtiff-params-filling.test.out
Size is 21, 11
Coordinate System is `'
Origin = (0.000000000000000,0.000000000000000)
Pixel Size = (0.000000000000000,102644816102343575529642170523847409907978314466155195571024509139884670043712327898328203264.000000000000000)
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (   0.0000000,   0.0000000) 
Lower Left  (       0.000,1129092977125779272930019257104223797202268954783753224646277267718449350752043602925045415936.000) 
Upper Right (   0.0000000,   0.0000000) 
Lower Right (       0.000,1129092977125779272930019257104223797202268954783753224646277267718449350752043602925045415936.000) 
Center      (       0.000,564546488562889636465009628552111898601134477391876612323138633859224675376021801462522707968.000) 
Band 1 Block=21x11 Type=Int16, ColorInterp=Gray
  NoData Value=0

systemtest/testcases_services/test_wcps$ gdalinfo output/53-jpeg2000-params-filling.test.out 
Driver: JPEG2000/JPEG-2000 part 1 (ISO/IEC 15444-1)
Files: output/53-jpeg2000-params-filling.test.out
Size is 21, 11
Coordinate System is:
LOCAL_CS["unnamed",
    UNIT["unknown",1]]
Origin = (0.000000000000000,0.000000000000000)
Pixel Size = (0.000000000000000,-0.000000000000000)
Corner Coordinates:
Upper Left  (   0.0000000,   0.0000000) 
Lower Left  (   0.0000000,   0.0000000) 
Upper Right (   0.0000000,   0.0000000) 
Lower Right (   0.0000000,   0.0000000) 
Center      (   0.0000000,   0.0000000) 
Band 1 Block=21x11 Type=Int16, ColorInterp=Gray

Change History (4)

comment:1 Changed 3 years ago by pcampalani

  • Status changed from new to accepted

Guess the problem is here:

INFO:   WARN [15:03:01] EncodeDataExpr@157: GDAL extra CRS parameters not set due to error:
                                            The number of output dimensions 3 does not match the expected dimensionality: 2

Working on the fix.

comment:2 Changed 3 years ago by pcampalani

  • Keywords geo encoding tiff jp2 added
  • Summary changed from WCPS tests with tiff output fail to WC*S tests with geo binary output encoding fail

comment:3 Changed 3 years ago by pcampalani

I think we should be more strict here and throwing an exception instead of just a warning message in the log.
Is that ok?

comment:4 Changed 3 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in changeset:963f244.

Note: See TracTickets for help on using tickets.