Opened 3 years ago

Closed 3 years ago

#478 closed defect (fixed)

WCPS switch tests fail

Reported by: dmisev Owned by: vmerticariu
Priority: major Milestone: 9.0
Component: petascope Version: development
Keywords: Cc: mdumitru
Complexity: Medium

Description

These tests fail in the WCPS test

64-switch_scalar.test
for c in mr return encode(switch case c>20 return (char)2 case c>10 return (char)1 default return (char)0,"csv")
65-switch_array.test
for c in mr return encode(switch case c>0 return c default return (char)0,"csv")
66-switch_log.test
for c in mr return encode(switch case c>0 return log(c) default return (char)0,"csv")

with exception like

InternalComponentError: Error translating parsed abstract WCPS query to XML format.
	at petascope.util.ras.RasUtil.abstractWCPStoXML(RasUtil.java:238)
	at petascope.wcps.server.servlet.WcpsServlet.doPost(WcpsServlet.java:167)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:602)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.NullPointerException
	at petascope.wcps.grammar.ProcessingExpr.toXML(ProcessingExpr.java:40)
	at petascope.wcps.grammar.ReturnClause.toXML(ReturnClause.java:40)
	at petascope.wcps.grammar.WCPSRequest.toXML(WCPSRequest.java:71)
	at petascope.util.ras.RasUtil.abstractWCPStoXML(RasUtil.java:235)
	... 15 more

Change History (2)

comment:1 Changed 3 years ago by vmerticariu

I can not replicate with the latest version. Maybe there was a bug in one of the previous versions that got fixed with the latest patches?

Can you please try again and let me know?

comment:2 Changed 3 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

Indeed, seems like it's fixed now.

Note: See TracTickets for help on using tickets.