Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#431 closed feature (fixed)

Update supported base DB to postgres 9.0+

Reported by: abeccati Owned by: miracee
Priority: major Milestone: 9.0
Component: undecided Version: development
Keywords: Cc: pbaumann dmisev pcampalani
Complexity: Medium

Description

Seems appropriate to have this feature for rasdaman 9.0

Will require running tests on an updated postgres instance and spawning/addressing the related issues to be fixed, if any.

Change History (8)

comment:1 Changed 4 years ago by dmisev

I'm running postgres 9.1 since quite some time, all seems fine here.

comment:2 Changed 4 years ago by pbaumann

propose to run the systemtest on PG 9.x, and if all passes the same way as on 8.x then we can close the ticket.

comment:3 Changed 4 years ago by dmisev

I'm running it pretty often myself :) so we can close this if you ask me.

comment:4 Changed 4 years ago by miracee

Yeah!! my first ticket!

I not really thought about it - I always just installed the actual PostgreSQL version (9.2) and then rasdaman. After that I played with rasdaman and made tests. All worked fine.

There are architecture changes in version 9 but nothing that would break backward compatibility.

So it would really surprise me - and not just me - when there would be a problem.

Just let me make some additional tests and then it's free to close.

Regards,

Susanne

comment:5 Changed 4 years ago by miracee

Alan,

feel free to close the ticket. All my PostgreSQL 9.2 tests passed.

Regards,

Susanne

comment:6 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 4 years ago by pcampalani

Should we update this? page?

comment:8 Changed 4 years ago by dmisev

I've been using 9.1.9 for a long time, I think it would be safe to say 9.x as well

Note: See TracTickets for help on using tickets.