Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#395 closed defect (fixed)

Access Denied Error with 8.4.2-1 RPM

Reported by: ungarj Owned by: mrusu
Priority: major Milestone: 8.5
Component: undecided Version: 8.5
Keywords: Cc:
Complexity: Medium

Description

running WCPS queries with the newest RPMs (8.4.2-1) I get the
following error from the tomcat log:

rasj[0] RasRNPImplementation.executeGetFreeServer: 802
rasj[0] RasRNPImplementation.getFreeServer: RasManager Error: Access
denied, incorrect user/password.

It worked until 8.4.1-3 (tested it again) and didn't change any
configurations. No changes made on petascope.settings, rasconnect nor rasmgr.conf.

Do you happen to have an idea what I could have missed
during RPM creation of 8.4.2-1? Was there anything specific which
should have been considered?

Thanks, Joachim

Change History (12)

comment:1 Changed 4 years ago by ungarj

  • Owner changed from dmisev to pcampalani
  • Status changed from new to assigned

comment:2 Changed 4 years ago by ungarj

works again.

it seems the intermediate solution was given by ticket #397 (increasing countdown number in rasmgr.conf).

comment:3 Changed 4 years ago by ungarj

btw. using the newest nightly build.

Will check again with release 8.4.4 and decrease countdown again.

comment:4 Changed 4 years ago by mrusu

In 8.4.4 it should be fixed (patch from 29.05), the bug was introduced by the rasmgr P2P functionality and so it affected other components as well. Now it should work also without increasing the countdown.

comment:5 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 4 years ago by ungarj

  • Resolution fixed deleted
  • Status changed from closed to reopened

Have encountered same issue with 8.5.0-beta2 RPM.

comment:7 Changed 4 years ago by abeccati

  • Milestone set to 8.5
  • Owner changed from pcampalani to mrusu
  • Status changed from reopened to assigned
  • Version changed from 8.4 to 8.5

Might be a regression still related to p2p, assigning for check

comment:8 Changed 4 years ago by dmisev

  • Resolution set to fixed
  • Status changed from assigned to closed

I tested this directly with the RPMs in question and I'm 99% certain it's some local installation issue and not an issue in rasdaman itself.

comment:9 Changed 4 years ago by mrusu

I tested it on the current master and also couldn't reproduce it.

comment:10 Changed 4 years ago by abeccati

Just a note on testing. It should be tested on the release_8.5 branch, not the master which has more commits on it that do not belong to 8.5

comment:11 Changed 4 years ago by ungarj

The issue with 8.4 seemed to be a local one as well as it worked on other machines.

Using the workaround in #397 helped (increasing countdown & timeout values in rasmgr.conf) but not this time.

Any idea how to provide you with more valuable hints?

comment:12 Changed 4 years ago by mrusu

The rasmgr log could give some insights.

Note: See TracTickets for help on using tickets.