Opened 4 years ago

Closed 22 months ago

#265 closed defect (invalid)

WMS fill pyramid fails on large collections

Reported by: dmisev Owned by: dmisev
Priority: major Milestone: Future
Component: rasgeo Version: 8.3
Keywords: Cc: pbaumann
Complexity: Very Hard

Description

It fails to allocate memory as it seems, i.e. it needs to be fixed to fetch less data per transaction:

working on domain [0:180259,0:29695]:
   fetching map information from database...ok
   performing database update with pyramid:
      pyramid layer haiti_vnir_pyr, factor 0.5, target domain [0:90129,0:14847]...terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
Caught signal 6: Abort (ANSI) or IOT trap (4.2 BSD).
 Exiting.

fill_pyramid.sh: done.

Change History (2)

comment:1 Changed 4 years ago by pbaumann

  • Milestone set to Future

this request seems to try to scale a tile of about 9 GB. Hence, it may be a consequential of a base layer inserted untiled into the database, going away with fixing ticket #294. Hence, proper action is to resolve #294 and then check again.

The probable root cause, tiles larger than main memory, is a consequence of the architecture (and any architecture based on tiles), so it will not be addressed as such.

comment:2 Changed 22 months ago by dmisev

  • Complexity set to Very Hard
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.