Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#189 closed defect (fixed)

rasimport: Segmentation fault (core dumped)

Reported by: j.oosthoek@… Owned by:
Priority: blocker Milestone: 8.4
Component: rasgeo Version: 8.3
Keywords: rasimport, error, 8.3 Cc: HerzigA@…, dmisev
Complexity: Medium

Description

I receive an error running rasimport on http://planetary-earthserver.jacobs-university.de after yum update to the latest rasdaman community version.

I tried the following rasimport commands which fail:
cd /mnt/miraculix-earthserver/lighthouse_planetary_data_repository/pre_processed_early_service_DEMO_11-2011/May2012/Background/
rasimport -f themisday.tif -t GreyImage:GreySet -coll themisday
I get the following error: Segmentation fault (core dumped)

themisday.tif is HUGE (22GB) so I first though the size might be the reason.
But then I tried to add the following data which I had already added before:

cd /mnt/miraculix-earthserver/lighthouse_planetary_data_repository/pre_processed_early_service_DEMO_11-2011/May2012/CRISM/
rasimport -f crism_vnir.tif -t CRISMVNIRImage:CRISMVNIRSet -coll tempcrism
I get the same error.

Any idea what might be the problem here?

Change History (8)

comment:1 Changed 5 years ago by herziga@…

The most recent update is working fine for me, so no real idea. Things you could check though, are

  • is GDAL working
  • are MDD/set types correct
  • is nm_meta correctly initialised

but probably you haven't changed anything else on your system but rasdaman. You could run rasimport in debug mode, which could put us on the right track where/when rasimport fails.

comment:2 Changed 5 years ago by j.oosthoek@…

I reinstalled gdal, gdal-devel, gdal-java, gdal-python and now I receive the following rasimport error:

rasimport: symbol lookup error: rasimport: undefined symbol: _ZTI9r_GMarray

comment:3 Changed 5 years ago by j.oosthoek@…

When I do rasdl -p I get the following error:

Using error text file: /usr/share/rasdaman//errtxts
rasdl: rasdaman schema and database manipulation tool, rasdaman v8.3 on base DBMS pgsql -- generated on 11.07.2012 18:29:26.
Warning/error in AdminIf Connect:
SQLSTATE: 08001 SQLCODE: -402

Error: connect unsuccessful; wrong connect string '/' ?
EDL003 rasdaman error: 830: base DBMS Error: Cannot connect to base DBMS server (invalid connect string in rasmgr config file?).
rasdl done.

comment:5 Changed 5 years ago by j.oosthoek@…

I'm afraid that the following error is also related:

When I try the following query at http://planetary-earthserver.jacobs-university.de:8080/petascope/wcps:

for c in ( crismvnir )
          return
              encode( coverage histogram
                      over     $n x(0:9)
                      values   count(
                                   c.band90 >= 0.158676 + $n*(0.309063 - 0.158676)/10 and
                                   c.band90 < 0.158676 + (1+$n)*(0.309063 - 0.158676)/10),
                      "csv" )

I get the following error:
Error: Cannot build coverage metadata !!!

comment:6 Changed 5 years ago by j.oosthoek@…

UPDATE:
The WCS and WCPS errors described in the two comments above are solved.

The rasdl -p error can be fixed by using rasdl -p --connect RASBASE

Only the rasimport error remains which again says: Segmentation fault (core dumped)

comment:7 Changed 5 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

I think we fixed the segfault with the latest rasimport right? Will close the ticket.

comment:8 Changed 5 years ago by dmisev

  • Complexity set to Medium
  • Milestone set to 8.4
Note: See TracTickets for help on using tickets.