Opened 5 years ago

Closed 5 years ago

#184 closed defect (fixed)

List of coverages for WCPS requests not updated unless restart Petascope

Reported by: mase@… Owned by: pcampalani
Priority: major Milestone: 8.4
Component: petascope Version: 8.3
Keywords: Cc:
Complexity:

Description

I made some database changes adding Petascope metadata to ps_coverage and related tables. The new coverages appear in the list of coverages in a WCS GetCapabilities? response and I can do a DescribeCoverage? request to get a response from each of them. However, when I submited a WCPS request specifying one of the added coverages I got a error message about it being an unknown coverage. (catalina.out log output attached.) I think this is because in changing to use IDynamicMetadataSource the list of coverages from the database is only populated during servlet initialisation and not whenever the coverages() method is called. Re-starting Tomcat fixes the problem but I don't think it is intended that you have to restart Tomcat every time you add or change a coverage is it? At any rate, the list of coverages returned by WCS and those available for WCPS queries should be consistent.

Attachments (1)

catalina.out (5.8 KB) - added by mase@… 5 years ago.
Log file

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by mase@…

Log file

comment:1 Changed 5 years ago by dmisev

  • Owner changed from dmisev to pcampalani
  • Status changed from new to assigned

Piero, is this maybe related to the DynamicMetadataSource removing/adding? Please have a look when you're back.

comment:2 Changed 5 years ago by pcampalani

Things should have been safely restored in:


commit bb6a8594714689c7e7dc81f792af07a91b25a434
Author: Piero Campalani <cmppri@…>
Date: Wed Jul 4 09:37:11 2012 +0200

Restore DynamicMetadataSource? for WCPS temporary coverages.


mase@…: at which commit are you ?

comment:3 Changed 5 years ago by mase@…

I'm using 8.3.1 RPMs which correspond to commit v8.3.1-g6ef7dbc according to Dimitar.

comment:4 Changed 5 years ago by pcampalani

It should be this one, dated 27 March:


commit 9219803b973a57bc81eede93fbb7cdf34a77128a (tag: refs/tags/v8.3.1)
Author: Ernesto Rodriguez <ernesto4160@…>
Date: Tue Mar 27 13:19:52 2012 +0200

Added Crs(String) constructor again. Fixes compile error of Petascope


If Dimitar confirms, I suggest to wait for a newer RPM version and see if the problem persists.

comment:5 Changed 5 years ago by mase@…

I have just tested with RPM 8.3.1-0.el6 and confirmed that the problem is fixed so this issue can be closed.

comment:6 Changed 5 years ago by pcampalani

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.