Opened 5 years ago

Closed 5 years ago

#170 closed defect (fixed)

Petascope GetCapabilities response is invalid (schema)

Reported by: jpass@… Owned by: dmisev
Priority: major Milestone: 8.4
Component: petascope Version: 8.3
Keywords: wcs GetCapabilities schema Cc:
Complexity:

Description

My oXygen XML Editor (v.13.2) tells me that the GetCapabilities? response for my Petascope (WCS) service (as below) is invalid, because it cannot locate the schema document.

http://earthserver.bgs.ac.uk/petascope?service=WCS&Request=GetCapabilities&version=2.0.0&

The schemaLocation is reported as: xsi:schemaLocation="http://www.opengis.net/wcs/2.0 wcsAll.xsd"

Whereas it should be reported as probably...

xsi:schemaLocation="http://www.opengis.net/wcs/2.0 http://schemas.opengis.net/wcs/2.0/wcsAll.xsd"

Change History (1)

comment:1 Changed 5 years ago by j.yu

  • Resolution set to fixed
  • Status changed from new to closed

There is a small modification on the online xsd (to be updated according to WCS 2.0 corrigenda). You can have a look at the latest xsd. e.g http://eoxserver.org/browser/sandbox/sandbox_schemas/schemas.

Note: See TracTickets for help on using tickets.