Opened 5 weeks ago

Closed 4 weeks ago

#1608 closed defect (invalid)

Build_GDAL should not be required when -DENABLE_GDAL=OFF

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.5
Component: build system Version: development
Keywords: Cc: dmisev
Complexity: Medium

Description

With cmake -DENABLE_GDAL=OFF will not build rasdaman with GDAL but actually it still requires the package (e.g: libgdal-dev in Debian) or it cannot run cmake configuration, example cmake configuration

cmake  ../rasdaman/ -DCMAKE_INSTALL_PREFIX=/opt/rasdaman/ -DENABLE_JAVA=OFF -DENABLE_GDAL=OFF -DNETWORK_PROTOCOL=rnp

Also it should work the same way as automake with --disable-gdal.

Change History (1)

comment:1 Changed 4 weeks ago by bphamhuu

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.