Opened 5 years ago

Closed 5 years ago

#160 closed defect (fixed)

sdom(c)[0].hi returns wrong result

Reported by: dmisev Owned by:
Priority: major Milestone: 8.4
Component: rasserver Version: 8.3
Keywords: Cc: pbaumann
Complexity:

Description

The query below doesn't return the expected result:

select sdom(c)[0].hi from COLL as c

e.g.

$ rasql -q 'select sdom(c)[0] from rgb as c' --out string
rasql: rasdaman query tool v1.0, rasdaman v8 -- generated on 03.06.2012 22:10:58.
opening database RASBASE at localhost:7001...ok
Executing retrieval query...ok
Query result collection has 1 element(s):
  Result element 1: 0:399
rasql done.

dimitar@blade:~$ rasql -q 'select sdom(c)[1].hi from rgb as c' --out string
rasql: rasdaman query tool v1.0, rasdaman v8 -- generated on 03.06.2012 22:10:58.
opening database RASBASE at localhost:7001...ok
Executing retrieval query...ok
Query result collection has 1 element(s):
  Result element 1: 1459683328
rasql done.

$ rasql -q 'select sdom(c)[0].hi from rgb as c' --out string
rasql: rasdaman query tool v1.0, rasdaman v8 -- generated on 03.06.2012 22:10:58.
opening database RASBASE at localhost:7001...ok
Executing retrieval query...ok
Query result collection has 1 element(s):
  Result element 1: -1895759872
rasql done.

Change History (1)

comment:1 Changed 5 years ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this problem anymore.. so closing the ticket.

Note: See TracTickets for help on using tickets.