Opened 3 weeks ago

Last modified 3 weeks ago

#1599 new defect

SECORE_Change to use Spring Boot framework

Reported by: bphamhuu Owned by:
Priority: major Milestone: 9.5
Component: secore Version: development
Keywords: Cc: dmisev, vmerticariu, pbaumann
Complexity: Medium

Description

SECORE is using outdated servlet and it should be good to change it to use Spring Boot framework as Petascope in version 9.5. It does not have problems with database, migration,... so should not take long time. The benefit is one can maintain easier and SECORE can run as a standalone application by Tomcat embedded.

Change History (2)

comment:1 follow-up: Changed 3 weeks ago by dmisev

How much effort in days would this be?

comment:2 in reply to: ↑ 1 Changed 3 weeks ago by bphamhuu

Replying to dmisev:

How much effort in days would this be?

1 - 2 weeks, depending on how I can understand SECORE (current not much).

Note: See TracTickets for help on using tickets.