Opened 4 weeks ago

Closed 4 weeks ago

#1598 closed defect (fixed)

Petascope_Cannot delete coverage with error in metadata

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.4
Component: petascope Version: development
Keywords: Cc: dmisev, vmerticariu
Complexity: Medium

Description

In Petascope version 9.4 and older, when DeleteCoverage? is requested, it needs to read the coverage metadata before trying to delete metadata from petascopedb and rasdaman collection.

However, if irregular coverage has error in metadata, such as

Coverage 'test_irr_cube_2 has a wrong number of coefficients for axis 3 (4) and is not consistent with its rasdaman `sdom' (4).

Then the DeleteCoverage? request cannot be done.

It should not read the whole coverage metadata but only rasdaman collection (oid, collectionname) and that is enough to delete coverage as petascopedb supports the cascade delete with coveargeId.

Change History (1)

comment:1 Changed 4 weeks ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.