Opened 5 weeks ago

Closed 4 weeks ago

#1585 closed defect (fixed)

Raswct sends raw POST WCPS request to Petascope

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.5
Component: raswct Version: development
Keywords: Cc: dmisev, vmerticariu
Complexity: Medium

Description

The problem is from raswct as it should send a WCPS with raw POST request to Petascope as the older one in Earthlook client (http://standards.rasdaman.com/).

The new change in raswct, I'm not sure since when, it uses a new javascript method to send an ajax request with incorrect POST payload as KVP:

request=<?xml version ="1.0" ....> <ProcessCoveragesRequest>...</ProcessCoveragesRequest>

When it should be only:

<?xml version ="1.0" ....> <ProcessCoveragesRequest>...</ProcessCoveragesRequest>

I copied the old method from Earthlook client to replace the new raswct.js file in http://tutorial.rasdaman.org/rasdaman-and-ogc-ws-tutorial/ so it could work now.

Change History (1)

comment:1 Changed 4 weeks ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.