Opened 3 months ago

Closed 7 weeks ago

#1570 closed defect (fixed)

Temporary problem when reinserting WMS styles

Reported by: dmisev Owned by: bphamhuu
Priority: major Milestone: 9.5
Component: petascope Version: development
Keywords: Cc:
Complexity: Medium

Description

After successfully inserting a new style(e.g.C0117051747_2465_30_gy) for any coverage(e.g. C0117051747_2465_30)
I can use WMS to request a png image via browser.

http://192.168.20.48:8080/rasdaman/ows?service=WMS&version=1.3.0&request=InsertStyle&name=C0117051747_2465_30_gy&layer=C0117051747_2465_30&abstract=greypng&rasqlTransformFragment={ (char)(255*($Iterator+1.370649) / 0.6659974) }

If I want to change some values(1.370649 or 0.6659974 with for example 0.912 instead of 1.370649) in above InsertStyle? request
I deleted the the style(e.g.C0117051747_2465_30_gy) with:

http://192.168.20.48:8080/rasdaman/ows?service=WMS&version=1.3.0&request=DeleteStyle&layer=C0117051747_2465_30&style=C0117051747_2465_30_gy

Then I insterted successfully a new style with new value(s) in formula:

http://192.168.20.48:8080/rasdaman/ows?service=WMS&version=1.3.0&request=InsertStyle&name=C0117051747_2465_30_gy&layer=C0117051747_2465_30&abstract=greypng&rasqlTransformFragment={ (char)(255*($Iterator+0.912) / 0.6659974) }

From WMS request for png image via browser

http://192.168.20.48:8080/rasdaman/ows?service=WMS&version=1.3.0&request=GetMap&layers=C0117051747_2465_30&styles=C0117051747_2465_30_gy&bbox=45.22131042101,-74.2526325472,45.9171011168,-72.8297311243&crs=EPSG:4326&width=768&height=390&format=image/png&TRANSPARENT=TRUE

I got a white image.
When I changed bbox coordinates for example from bbox=45.22131042101,-74.2526325472,45.9171011168,-72.8297311243 to bbox=45.45,-74.01,45.8,-72.67 I had a normal/nice image with WMS request in my browser.

Change History (5)

comment:1 Changed 3 months ago by bphamhuu

can you provide the coverage you ingested as WMS layer? as the problem with coordinates seem tricky to reproduce.

comment:2 Changed 3 months ago by dmisev

hmm I thought it always happened (i.e. there's some caching issue).

You cannot reproduce it?

comment:3 Changed 3 months ago by dmisev

I thought this would be the way to reproduce:

  1. WMS request with bbox A
  2. delete style
  3. insert slightly modified style
  4. WMS request with same bbox A -> white image
  5. WMS request with slightly changed bbox B -> correct output

comment:4 Changed 3 months ago by bphamhuu

ok, I will look at this in WMS of new Petascope, if it is problem with cache then I also need to take care about it for your case.

comment:5 Changed 7 weeks ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed

fixed in 9.5, all WMS requests containing styles, layers in cache will be removed when the layers, styles are deleted.

Note: See TracTickets for help on using tickets.