Opened 6 months ago

Closed 3 weeks ago

#1486 closed defect (fixed)

maven warning on building Petascope

Reported by: pbaumann Owned by: bphamhuu
Priority: minor Milestone: 10.0
Component: build system Version: development
Keywords: Cc:
Complexity: Medium

Description

on my Ubuntu 14.04 I get this during "make":

...
make[3]: Entering directory `/opt/rasdaman/source/applications/petascope'
cp pom.xml.in pom.xml
/bin/sed -i "s|@PROJECT_VERSION@|9.3.0|g" pom.xml
/bin/sed -i "s|@PETASCOPE_TARGET_DIR@|target|g" pom.xml
/bin/sed -i "s|@RASJ_PATH@|\${project.basedir}/lib/rasj.jar|g" pom.xml
/bin/sed 's|@CONF_DIR@|/opt/rasdaman/etc/|g' src/main/webapp/WEB-INF/web.xml.in > src/main/webapp/WEB-INF/web.xml
mvn package -Ppetascope
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.rasdaman:petascope:war:9.3.0
[WARNING] 'profiles.profile[petascope].dependencies.dependency.systemPath' for gt9:gt9:jar should not point at files within the project directory, ${project.basedir}/lib/gt9.jar will be unresolvable by dependent projects @ line 266, column 33
[WARNING] 'profiles.profile[petascope].dependencies.dependency.systemPath' for wcs-v:wcs-v:jar should not point at files within the project directory, ${project.basedir}/lib/wcs-v_1_1_0-schema-1.0-SNAPSHOT.jar will be unresolvable by dependent projects @ line 274, column 33
[WARNING] 'profiles.profile[petascope].dependencies.dependency.systemPath' for ows-v:ows-v:jar should not point at files within the project directory, ${project.basedir}/lib/ows-v_1_0_0-schema-1.0-SNAPSHOT.jar will be unresolvable by dependent projects @ line 282, column 33
[WARNING] 'profiles.profile[petascope].dependencies.dependency.systemPath' for gml-v:gml-v:jar should not point at files within the project directory, ${project.basedir}/lib/gml-v_3_1_1-schema-1.0-SNAPSHOT.jar will be unresolvable by dependent projects @ line 290, column 33
[WARNING] 'profiles.profile[petascope].dependencies.dependency.systemPath' for org.rasdaman:rasj:jar should not point at files within the project directory, ${project.basedir}/lib/rasj.jar will be unresolvable by dependent projects @ line 298, column 33
[WARNING] 'profiles.profile[jetty].dependencies.dependency.systemPath' for org.eclipse:jetty-server-all:jar should not point at files within the project directory, ${project.basedir}/jetty/jetty.jar will be unresolvable by dependent projects @ line 421, column 33
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
...

The cause of this warning should be eliminated.

Change History (2)

comment:1 Changed 4 months ago by dmisev

  • Owner changed from dmisev to bphamhuu
  • Status changed from new to assigned

comment:2 Changed 3 weeks ago by bphamhuu

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Summary changed from maven warning on building rasj to maven warning on building Petascope

These warnings are from Maven when building Petascope. In new Petascope version 9.5, these dependencies are resolved/removed so no warning.

Note: See TracTickets for help on using tickets.