Opened 6 months ago

Closed 6 months ago

#1443 closed defect (fixed)

SECORE_Add a manual prefix for domain:host configuration when it is necessary

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.3
Component: secore Version: development
Keywords: secore prefix Cc: dmisev, vmerticariu
Complexity: Medium

Description

This is request from Vlad:

there is a real use-case behind this        

they have a tomcat server that they expose internally only          

and they have an apache server that they use to expose to the outside         

so they have http://rasdaman.nci.org.au/def/crs/ that is exposed to the outside world through apache
          
when you send a request to http://rasdaman.nci.org.au/def/crs/EPSG/0/, this one in turn redirects it to some internal IP:  http://127.0.0.1:8080/def/crs/         

so secore sees the request as comming from  http://127.0.0.1
          
so all the urls are going to start with  http://127.0.0.1
          
which is not accessible from the outside, thus incorrect

so instead of using current request domain (e.g: http://localhost:8080/), SECORE can have a property as same as in petascope.properties (secore_servlet_url), then in the resolved results, it can display such as:

http://secore.rasdaman.org/def/crs/epsg/0/4326
 parameter:     petascope_servlet_url
# purpose:       service endpoint can be set here.
# description:   This property is used by WCS GetCapabilities() response <ows:HTTP> element to give the service endpoint.
#                Leave it null in case you want Petascope to declare the service URL based on the first request it receives after deploy.
#                Set this parameter to your public service URL in case you are using a proxy.
# need to adapt: no

Change History (5)

comment:1 Changed 6 months ago by dmisev

  • Resolution set to worksforme
  • Status changed from new to closed

There is such a property in secore.properties already:

#
# Service URL, used in automatic substitution of URNs (urn:ogc:def)
#
service.url=http://www.opengis.net/def

comment:2 Changed 6 months ago by dmisev

  • Resolution worksforme deleted
  • Status changed from closed to reopened

But I realize it may not work as intended at the moment, please check it Bang.

comment:3 Changed 6 months ago by bphamhuu

it should be sync as same as in petascope.properties (about description, variable..) at least, anyway, I'll check it soon.

comment:4 Changed 6 months ago by dmisev

Looks fine as it is, please don't change the parameter name service.url; just needs to be checked whether it works actually.

comment:5 Changed 6 months ago by bphamhuu

  • Keywords secore prefix added
  • Resolution set to fixed
  • Status changed from reopened to closed

the patch was applied, close ticket.

Note: See TracTickets for help on using tickets.