Opened 6 months ago

Closed 6 months ago

#1442 closed defect (fixed)

Fix error with netCDF when time axis is set "dataBound=false"

Reported by: bphamhuu Owned by: vmerticariu
Priority: major Milestone: 9.3
Component: wcst_import Version: development
Keywords: dataBound, netCDF, remove crs Cc: dmisev, vmerticariu
Complexity: Medium

Description

The problem is due to when update coverage (e.g: a 3D coverage and each update slice is 2D and time axis is not belonged to the slice (it is set "dataBound=false" in general coverage for netCDF), the time axis is still taken into account as a compoundCRS and that will overwrite the domainElements of inputCoverage's metadata (slice).

This needs to be fixed in WCST_Import (for removing the axis which is marked "dataBound=false" and fixed in Petascope (for the shifting interval correctly when this CRS is removed).

Change History (1)

comment:1 Changed 6 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed

patch was applied, thanks to Vlad.

Note: See TracTickets for help on using tickets.