Opened 9 months ago

Closed 7 months ago

#1431 closed defect (fixed)

WMS_Wrong request bounding box from QGIS

Reported by: bphamhuu Owned by:
Priority: major Milestone: 9.3
Component: petascope Version: development
Keywords: QGIS, WMS Cc: dmisev
Complexity: Medium

Description

so there are 2 coverages with different bounding box

<Layer queryable="0" cascaded="0" opaque="1" noSubsets="0" fixedWidth="0" fixedHeight="0">
	<Title>test_wms1</Title>
	<Name>test_wms1</Name>
	<Abstract/>
	<CRS>EPSG:4326</CRS>
	<EX_GeographicBoundingBox>
		<westBoundLongitude>-180.0</westBoundLongitude>
		<eastBoundLongitude>180.0</eastBoundLongitude>
		<southBoundLatitude>-90.0</southBoundLatitude>
		<northBoundLatitude>90.0</northBoundLatitude>
	</EX_GeographicBoundingBox>
	<BoundingBox CRS="EPSG:4326" minx="-90.0" miny="-180.0" maxx="90.0" maxy="180.0"/>
	<Style>
		<Name>test_wms1</Name>
		<Title>Default Raster Style</Title>
		<Abstract>A default style that returns the layer exactly as it is stored</Abstract>
	</Style>
</Layer>
<Layer queryable="0" cascaded="0" opaque="1" noSubsets="0" fixedWidth="0" fixedHeight="0">
	<Title>test_wms2</Title>
	<Name>test_wms2</Name>
	<Abstract/>
	<CRS>EPSG:4326</CRS>
	<EX_GeographicBoundingBox>
		<westBoundLongitude>20.0</westBoundLongitude>
		<eastBoundLongitude>30.0</eastBoundLongitude>
		<southBoundLatitude>20.0</southBoundLatitude>
		<northBoundLatitude>30.0</northBoundLatitude>
	</EX_GeographicBoundingBox>
	<BoundingBox CRS="EPSG:4326" minx="20.0" miny="20.0" maxx="30.0" maxy="30.0"/>

Then after QGIS getCapabilities, it will have a request with test_wms1's bounding box from like this when add test_wms2 as layer.

http://localhost:8080/rasdaman/ows?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&
BBOX=-90,44.19140625,53.47265625,138.69140625&CRS=EPSG:4326&WIDTH=681&HEIGHT=448
&LAYERS=test_wms2&STYLES=&FORMAT=image/png&DPI=96&MAP_RESOLUTION=96&FORMAT_OPTIONS=dpi:96&TRANSPARENT=TRUE)

it should use bounding box of wms_test2 in request.

Change History (3)

comment:1 Changed 9 months ago by dmisev

so is that a QGIS problem or rasdaman problem?

comment:2 Changed 9 months ago by bphamhuu

it seems only the last layer can be displayed and other previous layers will have error from QGIS

Invalid Layer: WMS provider Cannot calculate extent Raster layer Provider is not valid 
(provider: wms, URI: IgnoreAxisOrientation=1&IgnoreGetFeatureInfoUrl=1&IgnoreGetMapUrl=1&
contextualWMSLegend=0&crs=EPSG:4326&dpiMode=7&featureCount=10
&format=image/png&layers=test_wms1&styles=&url=http://localhost:8080/rasdaman/ows

I don't think it is QGIS problem now.

comment:3 Changed 7 months ago by bphamhuu

  • Keywords QGIS WMS added
  • Resolution set to fixed
  • Status changed from new to closed

the problem is the GetCapabilities? is not valid in WMS, it should be

<Layer>

...

<Layer/>
<Layer/>

<Layer>

then QGIS can parse the layers correctly, close as patch was applied.

Note: See TracTickets for help on using tickets.