Opened 8 months ago

Closed 5 months ago

#1420 closed defect (fixed)

add wcst_import test for grib data

Reported by: dmisev Owned by: bphamhuu
Priority: major Milestone: 9.3
Component: systemtest Version: development
Keywords: Cc: mdumitru, vmerticariu
Complexity: Medium

Description

There are no such tests in the systemtest. You can find some sample data in testcases_mandatory/test_grib for example (perhaps Alex has something locally and can provide that as well).

Change History (3)

comment:1 Changed 7 months ago by bphamhuu

it is hard to import coverage in grib as I don't have experience with this file!

Using the sample test file from systemtest/testcases_mandatory/test_grib/testdata/test5messages.grib2 with the recipe https://www.diffchecker.com/M6kGRLaz (which is set to fix value to bypass the check in Petascope bounds

 <ows:ExceptionText>The grid domain of the update input coverage ... 
is incompatible with the computed grid domain in the target coverage ...

) it will have other error later in Rasql.

16: Request: 'UPDATE test_grib_3d SET test_grib_3d[0:0,0:718,0:359] 
ASSIGN shift(decode(#MDD0#, "GRIB", "{\"internalStructure\":{\"messageDomains\":
[{\"msgId\":1,\"domain\":\"[0:0,0:718,0:359]\"},
{\"msgId\":2,\"domain\":\"[0:0,0:718,0:359]\"},
{\"msgId\":3,\"domain\":\"[0:0,0:718,0:359]\"},
{\"msgId\":4,\"domain\":\"[0:0,0:718,0:359]\"},
{\"msgId\":5,\"domain\":\"[0:0,0:718,0:359]\"}]}}"), [0,0,0]) WHERE oid(test_grib_3d) = 29185'...
 [INFO] - 14/11/2016 15:08:50.247730: parsing...
 [INFO] - 14/11/2016 15:08:50.247841: checking semantics...
 [INFO] - 14/11/2016 15:08:50.247920: evaluating...
[ERROR] - 14/11/2016 15:08:50.250168, /home/rasdaman/test_patch/rasdaman/conversion/grib.cc:367:
 the x grid size of the grib message (Ni) '720' 
does not match the x bound specified in the message domains '719'
Error number: 381 Token: decode Line: 1 Column: 68

It seems this coverage should have domain: 0:719 (as it has 720 points for lon), 0:360 (as it has 361 points for lat).

The problem is I don't understand how this bound is calculated in grib recipe of wcst_import to Petascope so could only test by try to fix the min and max variables.

comment:2 Changed 7 months ago by dmisev

  • Cc vmerticariu added

comment:3 Changed 5 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from new to closed

the patch was applied.

Note: See TracTickets for help on using tickets.