Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#139 closed defect (duplicate)

rasdl basetype deletion issue

Reported by: beccati@… Owned by:
Priority: major Milestone: 8.4
Component: rasdl Version: 8.3
Keywords: Cc:
Complexity: Medium

Description

Cannot delete a basetype with rasdl, here follows command sequence.

$ rasdl -p | grep Mod
typedef struct { float level01, float level02, float level03, float level04, float level05, float level06, float level07, float level08, float level09, float level10, float level11, float level12, float level13, float level14, float level15, float level16, float level17, float level18, float level19, float level20 } ModP20Pixel;

$ rasdl --delbasetype ModP20Pixel
Using error text file: /usr/local/rasdaman8.3/share/rasdamanerrtxts
rasdl: rasdaman schema and database manipulation tool, rasdaman v8.3 on base DBMS pgsql -- generated on 31.01.2012 17:14:19.
Deleting basetype ModP20Pixel...ok
rasdl done.

$ rasdl -p | grep Mod
typedef struct { float level01, float level02, float level03, float level04, float level05, float level06, float level07, float level08, float level09, float level10, float level11, float level12, float level13, float level14, float level15, float level16, float level17, float level18, float level19, float level20 } ModP20Pixel;

As you can see the type is reported as deleted but it is still present and listed by rasdl -p

There are no other mdd or set types using it.
Alan

Change History (4)

comment:1 Changed 5 years ago by dmisev

  • Resolution set to duplicate
  • Status changed from new to closed

Are there any collections using the type? See #134 I'll close this as duplicate (please reopen if it isn't the case)

comment:2 Changed 3 years ago by pcampalani

  • Complexity set to Very Hard

It might not be a duplicate of #134: here the issue is that (I am facing it too now) a type cannot be dropped; there it is about proper logging.

I understand that the correct order of deletion when defining custom data types is SETs then MDDs then BASIC types: outer to inner: maybe Alan you were trying to drop the base type first?

I cannot reproduce my problem, since now it got back working after I manually DELETEd my types from ras_* related tables.

Alan, do you still have this issue?

comment:3 Changed 3 years ago by pcampalani

  • Complexity changed from Very Hard to Medium

comment:4 Changed 3 years ago by dmisev

The correct order is as you specified, but first of all you must drop all collection that may be using that type. The main issue is that an error message is not printed, otherwise in my experience dropping types works fine when done correctly.

Note: See TracTickets for help on using tickets.