Opened 14 months ago

Closed 6 months ago

#1200 closed defect (fixed)

Petascope error when parsing compound CRS by wcst_import with wcs_extract recipe

Reported by: bphamhuu Owned by:
Priority: major Milestone: 9.3
Component: petascope Version: development
Keywords: petascope error Cc: mdumitru
Complexity: Medium

Description

I've tested wcst_import a coverage (eobstest) which has time axis from local petascope with recipe "wcs_extract"

{
  "config": {
    "service_url": "http://localhost:8088/rasdaman/ows",
    "tmp_directory": "/tmp/",
    "crs_resolver": "http://localhost:8080/def/",
    "default_crs": "http://localhost:8080/def/crs/EPSG/0/4326",
    "mock": false,
    "automated": true,
    "subset_correction" : false
  },
  "input": {
    "coverage_id": "NIR2324"
  },
  "recipe": {
    "name": "wcs_extract",
    "options": {
      "coverage_id": "eobstest",
      "wcs_endpoint" : "http://localhost:8088/rasdaman/ows",
      "wms_import": true
    }
  }
}

and it throw an error in WCST_Import ( I could not see this problem in petascope.log ), SECORE is working normally with this compound CRS definition

http://localhost:8080/def/crs-compound?1=http://localhost:8080/def/crs/OGC/0/Temporal?epoch=%221950-01-01T00:00:00%22&uom=%22d%22&2=http://localhost:8080/def/crs/EPSG/0/4326
<CompoundCRS xmlns:gml="http://www.opengis.net/gml/3.2" xmlns:epsg="urn:x-ogp:spec:schema-xsd:EPSG:0.1:dataset" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:gco="http://www.isotc211.org/2005/gco" xmlns:gmd="http://www.isotc211.org/2005/gmd" gml:id="crs">
<metaDataProperty>
<epsg:CommonMetaData>
<epsg:type>compound</epsg:type>
</epsg:CommonMetaData>
</metaDataProperty>
<scope>not known</scope>
<identifier codeSpace="OGC">
http://localhost:8080/def/crs-compound?1=http://localhost:8080/def/crs/OGC/0/Temporal?epoch=%221950-01-01T00:00:00%22%26uom=%22d%22%262=http://localhost:8080/def/crs/EPSG/0/4326
</identifier>
<name>null / WGS 84</name>
<componentReferenceSystem xlink:href="http://localhost:8080/def/crs/OGC/0/Temporal?epoch="1950-01-01T00:00:00"%26uom="d""/>
<componentReferenceSystem xlink:href="http://localhost:8080/def/crs/EPSG/0/4326/"/>
</CompoundCRS>

Error here

RUNTIME ERROR: We could not parse the compound crs at http://localhost:8080/def/crs-compound?
1=http://localhost:8080/def/crs/OGC/0/Temporal?epoch="1950-01-01T00:00:00"
&uom="d"&2=http://localhost:8080/def/crs/EPSG/0/4326. 
Please check that the url is correct. 
Detailed error: RUNTIME ERROR: We could not parse the crs 
at http://localhost:8080/def/crs/OGC/0/Temporal?epoch="1950-01-01T00:00:00".
Please check that the url is correct.

Change History (1)

comment:1 Changed 6 months ago by bphamhuu

  • Milestone changed from 10.0 to 9.3
  • Resolution set to fixed
  • Status changed from new to closed

The problem is due to the " in the timeCrs's parameter which was fixed in wcst_import, close ticket.

Note: See TracTickets for help on using tickets.