Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#117 closed defect (invalid)

inv_tiff broken in rasdaman 8.3

Reported by: beccati@… Owned by: pbaumann
Priority: major Milestone: 8.4
Component: conversion Version: 8.3
Keywords: Cc:
Complexity: Medium

Description

The inv_tiff converter is broken in 8.3, to reproduce the issue:

Insert mr_1.tif into mr collection
rasql -q "insert into mr values inv_tiff(\$1) " -f mr_1.tif --user rasadmin --passwd rasadmin

Get the last oid
rasql -q "select oid(t) from mr as t" --out string

esport it as png image
rasql -q "select png(t) from mr as t where oid(t) = 24065" --out file

Attached the resulting file renamed as broken-mr_1.png
See if it happens also on your installation


OS info:
lsb_release -a
LSB Version: :core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: Scientific
Description: Scientific Linux release 6.0 (Carbon)
Release: 6.0
Codename: Carbon

gcc --version
gcc (GCC) 4.4.4 20100726 (Red Hat 4.4.4-13)
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Attachments (3)

broken-mr_1.png (5.5 KB) - added by beccati@… 6 years ago.
output of png extraction from mr collection
conversion_test.log (1.3 KB) - added by beccati@… 6 years ago.
Log of the system test for conversion
exportedtiff.tif (53.1 KB) - added by beccati@… 6 years ago.
exported data into tiff format has the same issue

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by beccati@…

output of png extraction from mr collection

comment:1 Changed 6 years ago by dmisev

That's strange, all seems to work well on Debian testing.

Can you maybe run the system test:

cd systemtest && make check

comment:2 Changed 6 years ago by dmisev

Do you get the same problem if you export to tiff (just to rule out that the problem is not in png)?

comment:3 Changed 6 years ago by beccati@…

Here is the output of the system test:

Detail test report is in testcases_open/test_select/log
testcases_fixed/test_memleak/test.sh ... OK

see detail in testcases_fixed/test_memleak/log

testcases_mandatory/test_conversion/test.sh ... FAIL

see detail in testcases_mandatory/test_conversion/log

testcases_mandatory/test_manipulation/test.sh ... OK

see detail in testcases_mandatory/test_manipulation/log

testcases_mandatory/test_select/test.sh ... FAIL

see detail in testcases_mandatory/test_select/log

testcases_mandatory/test_user/test.sh ... FAIL

see detail in testcases_mandatory/test_user/log

testcases_open/test_select/test.sh ... OK

see detail in testcases_open/test_select/log

Attached the log of the conversion test

Changed 6 years ago by beccati@…

Log of the system test for conversion

Changed 6 years ago by beccati@…

exported data into tiff format has the same issue

comment:4 Changed 6 years ago by dmisev

Do you have the latest git version of rasdaman?
In the conversion log there should be a


entry which I don't see. I've submitted a patch to fix multiband TIFF import/export recently, it's likely that the bug you get has also been fixed.

comment:5 Changed 6 years ago by dmisev

that was supposed to be:

------tiff and inv_tiff multiband conversion------

comment:6 Changed 6 years ago by barboni@…

Hi Dimitar

I updated and recompiled rasdaman on Feb 6
The new version recompiled today works well

You can mark this ticket as "closed" or "invalid"

Ciao

Damiano

comment:7 Changed 5 years ago by dmisev

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 Changed 4 years ago by dmisev

  • Complexity set to Medium
  • Milestone set to 8.4
Note: See TracTickets for help on using tickets.