#1167 closed defect (fixed)

Petascope_insertdemo.sh should keep the band names after update

Reported by: mdumitru Owned by: mdumitru
Priority: major Milestone: 9.2
Component: petascope Version: development
Keywords: Cc:
Complexity: Medium

Description

After the last update, the default band name was changed from Gray to b1. This makes things confusing, especially when running the systemtests that make certain assumptions about the contents of your database.

Change History (4)

comment:1 Changed 17 months ago by pbaumann

This default name is quite randomly chosen. There are many possible interpretations of a single-channel array, such as radar, elevation, bathymetry, mask. What computer graphics calls "gray" (why would you capitalize?) is called panchromatic in remote sensing.

IMO there should not be a default band name at all.

Let us discuss this beyond 9.2.

comment:2 Changed 17 months ago by mdumitru

I agree that the name should be better. The problem is that this coverage is used both in systemtest and in the petascope demo data. If one user ingests this coverage using petascope_insertdemo and tries to run the systemtests, he will get an error due to the inconsistency.
One could argue that we can change the systemtests to not depend on the name, but unfortunately it is hardcoded in so many places that it would be futile at this point. Hopefully with the future test framework this won't be the case anymore.

comment:3 Changed 17 months ago by pbaumann

oh, I guess I misunderstood and it is just about not changing existing names. Agreed then.

comment:4 Changed 17 months ago by dmisev

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.