#1132 closed defect (fixed)

Missing detail information in log file of system test (test_wcs, test_wcps,...)

Reported by: bphamhuu Owned by: bphamhuu
Priority: major Milestone: 9.2
Component: systemtest Version: development
Keywords: Cc: dmisev
Complexity: Medium

Description

Before, the test query will also be added into log file to know which query was tested and the result (FAILED/PASSED). But now in log file, only meaningless information was logged.

test.sh:  ->  TEST FAILED
test.sh: http exit code comparison
test.sh:  ->  TEST PASSED
test.sh: http exit code comparison
test.sh:  ->  TEST PASSED
test.sh: http exit code comparison
test.sh:  ->  TEST PASSED
test.sh: http exit code comparison
test.sh:  ->  TEST PASSED

In console, the output still in detail and correct.

running test: 03-get_coverage.kvp

service=WCS&
version=2.0.1&
request=GetCoverage&
coverageId=mr

test.sh: Preparing XML file /home/rasdaman/test_server/test_1055/rasdaman/systemtest/testcases_services/test_wcs/output/03-get_coverage.kvp.out for oracle comparison... ok.
test.sh: byte comparison
test.sh:  ->  TEST PASSED
--------------------------------------------------------------------------------------------
running test: 03-get_coverage.xml

<?xml version="1.0" encoding="UTF-8"?>
<wcs:GetCoverage
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:wcs="http://www.opengis.net/wcs/2.0"
    xmlns:gml="http://www.opengis.net/gml/3.2"
    xsi:schemaLocation="http://schemas.opengis.net/wcs/2.0 ../wcsAll.xsd"
    service="WCS" version="2.0.1">
  <wcs:CoverageId>mr</wcs:CoverageId>
</wcs:GetCoverage>

test.sh: Preparing XML file /home/rasdaman/test_server/test_1055/rasdaman/systemtest/testcases_services/test_wcs/output/03-get_coverage.xml.out for oracle comparison... ok.
test.sh: byte comparison
test.sh:  ->  TEST PASSED

Attachments (1)

log (25.8 KB) - added by bphamhuu 18 months ago.
Example test_wcs log

Download all attachments as: .zip

Change History (5)

Changed 18 months ago by bphamhuu

Example test_wcs log

comment:1 Changed 18 months ago by dmisev

Hmm true. Can you try to find the issue?

And have you noticed this issue with the update properties test? Needs to be fixed too.

tee: /log: Permission denied
test.sh: --- Testing updating values between new and old configuration files ---
tee: /log: Permission denied
test.sh: Preparing input data directories.
tee: /log: Permission denied
test.sh: Done.
Number of files to test is: 1
tee: /log: Permission denied
test.sh: Comparing output file:
tee: /log: Permission denied
test.sh: +testcases_services/test_update_properties/data/old/petascope.properties_old
tee: /log: Permission denied
test.sh: +testcases_services/test_update_properties/oracle/petascope.properties_oracle
tee: /log: Permission denied
test.sh: Pass: Output file is identical to oracle file. Done.

tee: /log: Permission denied
test.sh: -------------------------------------------------------
tee: /log: Permission denied
test.sh: Test summary
tee: /log: Permission denied
test.sh: 
tee: /log: Permission denied
test.sh:   Test finished at: Fri Jan  8 00:04:22 CET 2016
tee: /log: Permission denied
test.sh:   Total tests run : 1
tee: /log: Permission denied
test.sh:   Successful tests: 1
tee: /log: Permission denied
test.sh:   Failed tests    : 0
tee: /log: Permission denied
test.sh:   Skipped tests   : 0
tee: /log: Permission denied
test.sh:   Detail test log : /log
tee: /log: Permission denied
test.sh: -------------------------------------------------------

comment:2 Changed 18 months ago by bphamhuu

@Dimitar: yes, I've noticed it yesterday and think will add it into ticket 1128 testing wcst_import, the problem is SCRIPT_DIR variable.

comment:3 Changed 18 months ago by bphamhuu

  • Owner set to bphamhuu
  • Status changed from new to assigned

comment:4 Changed 17 months ago by bphamhuu

  • Resolution set to fixed
  • Status changed from assigned to closed

patch was accepted, close ticket here.

Note: See TracTickets for help on using tickets.